HEXAQ : A friendly question - answer site for IT professionals

Login failed for user 'IIS APPPOOL \ DefaultAppPool'


0

In my development machine my project was working ok. I published and deployed it on our stage environment. When I open my home page, I encountered an error

Cannot open database "7StarCon" requested by the login. The login failed. Login failed for user 'IIS APPPOOL\DefaultAppPool'

Any guess whats wrong with my deployment?

Â
asked
 

@BoomDorje which version of IIS and OS you use?  - OscarWeb


≡ Total 2 Answers

0

If you are using IIS 7 or 7.5 do following changes in your settings

  • Open Internet Information Server (IIS)
  • Expand Application Pools
  • Select Application pool of your website
  • Click Advanced Settings from Actions pane (right side)
  • Set ApplicationPoolIdentity to NT AUTHORITY\SYSTEM if it is setto any other.
  • Recycle AppPool

Let me know if you are using other version of IIS.

Â
replied


0

Run you application as Administrator.

Â
replied


Enter your reply here
Answer Preview: